Why do I get FTP errors when using Internet Explorer?

Internet Explorer does not currently have the proper secure authentication protocols that are required by our FTP Server. Please use an FTP Client that is compatible with our FTP Server. We suggest using FileZilla; click here to visit their website and download the latest version.

  • 0 Users Found This Useful